Experiences in the community

Just another WordPress.com weblog

Third-party Repositories & headaches

Hi all,
Another Sunday. For last couple of days I have been fighting a bug on the latest Hardy & have been getting nowhere.

https://bugs.launchpad.net/bugs/188125

While I was talking to people on IRC I came to realize one of the things that a third party I subscribe to may have some influence to some extent in the things.

A package called libgnomevfs2

The repository I subscribe to for bleeding edge :- http://www.sofaraway.org/ubuntu/minirepos/

I’m subscribed to using the latest firefox build, the latest miro, gstreamer & other couple of packages.

While hunting for understanding what could be wrong, I came across this article/blog.

http://www.happyassassin.net/2007/10/24/mistakes/

so far making it authentic have to downgrade the packages.

The package as it was listed :-

shirish@Mugglewille:~$ apt-cache madison libgnomevfs2-0
libgnomevfs2-0 | 1:2.21.91+svn20080131r5441+bbot-1 | http://www.sofaraway.org gstreamer0.10/ Packages
libgnomevfs2-0 | 1:2.20.1-1ubuntu1 | http://archive.ubuntu.com hardy/main Packages
gnome-vfs | 1:2.20.1-1ubuntu1 | http://archive.ubuntu.com hardy/main Sources

The downgrade procedure :-

shirish@Mugglewille:~$ sudo aptitude install libgnomevfs2-0=1:2.20.1-1ubuntu1
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reading extended state information
Initializing package states… Done
Building tag database… Done
The following packages are BROKEN:
libgnomevfs2-0 libgnomevfs2-dev
0 packages upgraded, 0 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 261kB of archives. After unpacking 0B will be used.
The following packages have unmet dependencies:
libgnomevfs2-0: Depends: libgnomevfs2-common ( 1:2.20.1-1ubuntu1 (hardy)]
libgnomevfs2-extra [1:2.21.91+svn20080131r5441+bbot-1 (unstable, now) -> 1:2.20.1-1ubuntu1 (hardy)]

Score is 179

Accept this solution? [Y/n/q/?] Y
The following packages are unused and will be REMOVED:
libavahi-client-dev libavahi-common-dev libavahi-glib-dev libgconf2-dev libidl-dev liborbit2-dev
libselinux1-dev libsepol1-dev
The following packages will be automatically REMOVED:
libgnomevfs2-dev
The following packages will be DOWNGRADED:
libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra
The following packages will be REMOVED:
libgnomevfs2-dev
0 packages upgraded, 0 newly installed, 3 downgraded, 9 to remove and 0 not upgraded.
Need to get 1067kB of archives. After unpacking 10.2MB will be freed.
Do you want to continue? [Y/n/?] Y
Writing extended state information… Done
Get:1 http://archive.ubuntu.com hardy/main libgnomevfs2-extra 1:2.20.1-1ubuntu1 [88.3kB]
Get:2 http://archive.ubuntu.com hardy/main libgnomevfs2-0 1:2.20.1-1ubuntu1 [261kB]
Get:3 http://archive.ubuntu.com hardy/main libgnomevfs2-common 1:2.20.1-1ubuntu1 [718kB]
Fetched 1067kB in 1min55s (9216B/s)
(Reading database … 304193 files and directories currently installed.)
Removing libgnomevfs2-dev …
Removing libavahi-client-dev …
Removing libavahi-glib-dev …
Removing libavahi-common-dev …
Removing libgconf2-dev …
Removing liborbit2-dev …
Removing libidl-dev …
Removing libselinux1-dev …
Removing libsepol1-dev …
dpkg – warning: downgrading libgnomevfs2-extra from 1:2.21.91+svn20080131r5441+bbot-1 to 1:2.20.1-1ubuntu1.
(Reading database … 303689 files and directories currently installed.)
Preparing to replace libgnomevfs2-extra 1:2.21.91+svn20080131r5441+bbot-1 (using …/libgnomevfs2-extra_1%3a2.20.1-1ubuntu1_i386.deb) …
Unpacking replacement libgnomevfs2-extra …
dpkg – warning: downgrading libgnomevfs2-0 from 1:2.21.91+svn20080131r5441+bbot-1 to 1:2.20.1-1ubuntu1.
Preparing to replace libgnomevfs2-0 1:2.21.91+svn20080131r5441+bbot-1 (using …/libgnomevfs2-0_1%3a2.20.1-1ubuntu1_i386.deb) …
Unpacking replacement libgnomevfs2-0 …
dpkg – warning: downgrading libgnomevfs2-common from 1:2.21.91+svn20080131r5441+bbot-1 to 1:2.20.1-1ubuntu1.
Preparing to replace libgnomevfs2-common 1:2.21.91+svn20080131r5441+bbot-1 (using …/libgnomevfs2-common_1%3a2.20.1-1ubuntu1_all.deb) …
Unpacking replacement libgnomevfs2-common …
Setting up libgnomevfs2-common (1:2.20.1-1ubuntu1) …

Setting up libgnomevfs2-0 (1:2.20.1-1ubuntu1) …

Setting up libgnomevfs2-extra (1:2.20.1-1ubuntu1) …
Processing triggers for libc6 …
ldconfig deferred processing now taking place
Reading package lists… Done
Building dependency tree
Reading state information… Done
Reading extended state information
Initializing package states… Done
Writing extended state information… Done
Building tag database… Done

Atleast this is done, documenting for self. It took me lots of time to get it right because aptitude doesn’t tell what’s missing if the argument is not right. Of course its gonna take quite a bit of time to understand where things are going wrong. Also would be editing the third-party gstreamer so I can test packages from Hardy main rather than the repo for gstreamer atleast.

Of course the jury (i.e. me) is out whether after commenting will Hardy get the news & give me updates about gstreamer from its archive. It does logical that it should now that the other repository is down but still who knows. I intend to find out in the upcoming days.

An update :- Finally I’m synced with Hardy the downgrade is complete. I should thank Ubulette without whose help (alongwith the shell script) would have taken more days to complete. And at first glance things seem to be back to normal/good. Let’s see.

Add to FacebookAdd to NewsvineAdd to DiggAdd to Del.icio.usAdd to StumbleuponAdd to RedditAdd to BlinklistAdd to TwitterAdd to TechnoratiAdd to Furl

Single Post Navigation

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: